четверг, 17 мая 2012 г.

Второй параметр в методе "Выбрать". Группировки.

Сразу хочу предупредить, что вопрос освещаемый в этой статье очень специальный и если вы хотите увидеть общий обзор всего, да с практической пользой и применением, то лучше вам дальше не читать.
Тем же, кого, как и меня, беспокоил не не давал спокойно спать этот мелкий и назойливый вопрос "ну почему список" - добро пожаловать. Итак, интерес исключительно академический, практическая значимость сомнительна. Поехали!
Все началось с того, наш любимый синтакс помощник выдал мне вот такую справку:

РезультатЗапроса (QueryResult)
Выбрать (Choose)

Синтаксис:
Выбрать(<ТипОбхода>, <Группировки>, <ГруппировкиДляЗначенийГруппировок>)

Параметры:
<ТипОбхода> (необязательный)
Тип: ОбходРезультатаЗапроса.
Задает тип обхода записей в получаемой выборке.
Значение по умолчанию: Прямой

<Группировки> (необязательный)
Тип: Строка.
Список группировок по которым будет вестись обход, разделенных запятыми.
Для детальных записей указывается пустая строка. В случае, если группировки не указаны - будет использоваться следующая группировка, указанная в предложении запроса "ИТОГИ".

<ГруппировкиДляЗначенийГруппировок> (необязательный)
Тип: Строка.
Список группировок, из которых будут выбираться значения группировок для обхода, разделенных запятыми. Если указано "Все", то будут выбираться все значения группировок. Если указана пустая строка, то значения для группировок будут выбираться из предыдущей группировки.

Возвращаемое значение:
Тип: ВыборкаИзРезультатаЗапроса.

Описание:
Формирует выборку записей из результата запроса.

Доступность:
Сервер, толстый клиент, внешнее соединение.

Примечание:
Получение выборок очень большого размера (более 64Mb) требует наличия достаточного количества свободного места на диске, используемом для размещения временных файлов сервера и клиента.

Пример:
Выборка = РезультатЗапроса.Выбрать();
Казалось бы, всё понятно, все пользовались миллион раз. Но, обратите внимание, что в описании второго параметра написано:
Список группировок по которым будет вестись обход, разделенных запятыми.
Исходя из практики сразу скажу, что этот параметр используется редко даже с одной группировкой. Проще в самом запросе указать группировки в нужном порядке, чтобы потом по ним "идти", чем потом в коде пропускать какие-то группировки. Да, и вообще, как уже говорилось - СКД рулит. Но какое-то поведение все-таки закладывалось в метод, когда в параметре перечислен именно список группировок? Какое? Этот вопрос беспокоил не только меня, но интернет предательски молчал.
Вот те мучающиеся вопросом бедолаги, которых мне удалость разыскать (всем привет!):
Миста и Итланд:
1С, версия для обучения:
1С, форум специалистов:
Ответы однообразны: а зачем тебе это, делай лучше так...

Но мы же договорились, что нами движет академический интерес?
Давайте разберемся что же именно "знает" выборка из результатов запроса и что "знает" выборка из выборки?
Если мы, как обычно, напишем:
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой);

То объект "Выборка" будет "знать" (хранить информацию) о всех данных, которые вернул запрос. Заметьте, я специально не опускал первый параметр, хотя по-умолчанию и так подставляется прямой тип обхода. При этом, если в запросе были группировки, то на каждом шаге выборки мы получим разный тип записи запроса (см. метод Выборка.ТипЗаписи) и разный уровень группировок (см. метод Выборка.Уровень).

Если же у нас в запросе есть несколько группировок, например "Склад, Номенклатура, ХарактеристикаНоменклатуры, Регистратор" (ИТОГИ, ну вы помните) и мы представим такую конструкцию:
ВыборкаСклад = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Склад");
Пока
ВыборкаСклад.Следующий() Цикл

   
ВыборкаНоменклатура = ВыборкаСклад.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Номенклатура");
    Пока
ВыборкаНоменклатура.Следующий() Цикл

       
ВыборкаХарактеристикаНоменклатуры = ВыборкаНоменклатура.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "ХарактеристикаНоменклатуры");
        Пока
ВыборкаХарактеристикаНоменклатуры.Следующий() Цикл



        КонецЦикла;

    КонецЦикла;

КонецЦикла;

То объект "ВыборкаСклад" будет знать только о единственном уровне группировок "Склад" и остальные для него значения не имеют. И хотя он позволит опуститься на уровень ниже, но "ВыборкаНоменклатура" это уже другой объект со своим "знанием" для которого, опять-таки, существует единственная группировка - "Номенклатура". Т.е. сам первый параметр определяет будет ли созданный объект обладать информацией о всех уровнях группировки или только об одном. Такие слова как "два уровня"  или "три уровня" тут неуместны.

Жаль, что метод "Выбрать" нельзя "раскрутить" и посмотреть изнутри, было бы любопытно как оно устроено. Но, имеем черный ящик, с чем и живем.

Зато, посмотрите как просто группируются записи по нескольким группировкам, при прямой выборке:
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой, "Номенклатура,ХарактеристикаНоменклатуры", ",");

Чем это отличается от выборки без второго и третьего параметров? Только тем, что итоговые записи будут исключительно по указанным группировкам, причем, в итоговой записи "Номенклатура", например, не будет склада, так как по нему не проводилась группировка.
Тут важно отметить одну тонкость. Даже если вы хотите опустить третий параметр метода "Выбрать", количество группировок для значений группировок указать придется, как это сделал я, вставив туда запятую. А вообще правильно было бы сделать, например, так:
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой, "Склад,Номенклатура", "Все,Склад");

Итак, подытожу. Бесполезное знание и бестолковый параметр метода. Нет золота в серых горах. Увы. =(

P.S.: Вот переписка с 1С на эту тему, может кого-то занинтересует:
>> В каком случае во втором параметреиспользуется ИМЕННО СПИСОК группировок разделенных запятыми, какое при этом поведение выборки, и нет ли наглядного примера иллюстрирующего такой случай?
<< Список группировок можно применять когда требуется получить группировку выборку по указанным полям.
<< Пример: РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.Прямой, "Товар,Покупатель", "Все,Товар");
>> Верно ли я понимаю, что использовать список группировок во втором параметре можно _только_ с типом обхода результата запроса "ОбходРезультатаЗапроса.Прямой"?
<< Да, с другими типами обхода при выборке получается только один уровень, поэтому указывать вторую группировку бессмысленно.
Извините.

Публикация на Инфостарт

Комментариев нет:

Отправить комментарий