воскресенье, 31 марта 2013 г.

Лас-Вегас!!!

У нас было 2 программиста, 75 страниц исходного кода, 5 листов блок-схем, 1/2 зарядки ноутбука и целое множество документации всевозможных авторов и изданий, а так же компилятор, среда разработки, редактор графического интерфейса и структура проекта. Не то, что бы это было слишком сложно, но если начал писать программу, становится трудно остановиться. Единственное, что у меня вызвало опасение - это ассемблер. Нет ничего более изощренного, безответственного и неоправданного, чем писать на ассемблере. Я знал, что рано или поздно мы перейдем и на эту дрянь.
Один хороший паблик.

пятница, 29 марта 2013 г.

Google Reader

Жаль, но компания Жужл (читай Империя Зла) объявила, что закрывает Google Reader. В чем провинился скромный агрегатор RSS совершенно не понятно. Ну, прекратили бы поддержку и развитие, оставив же закостенелых пользователей в покое. Но, нет! Надо закрыть.
Стратегия компании понятна - хороший годный сервис не приносит бабла и оттягивает юзеров от жужл+

Короче, тут уже все думают куда валить с ридера, а некоторые пишут петиции. Я себе присмотрел запасной вариант, но петицию подписал. Вряд ли поможет, но все же.

среда, 27 марта 2013 г.

Директивы выбора контекста исполнения

Обновляли УПП с версии (1.3.15.6) до (1.3.21.2), платформа (8.2.17.169)

В конфигурации использовался перенос данных в идентичную конфигурацию, с помощью стандартной обработки "УниверсальныйОбменДаннымиXML" в режиме прямого подключения (не файлом) к БД-приемнику. Обработка вызывалась программно (не интерактивно), заполнялись реквизиты и автоматически включался перенос вызовом "ВыполнитьВыгрузку()".

После обновления перенос перестал работать, более того, появились странные вылетания процесса 1С.

Анализ показал следующее -

В технологическом журнале ловится эксепшн "EXCP" со следующим контекстом:

Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта : 12139 : ЗаписатьВПротоколВыполнения("Начало загрузки: " + ТекущаяДата(), , Ложь, , , Истина);
Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта : 1476 : СообщитьПользователю(ИтоговаяСтрокаДляЗаписи);
Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта : 14044 : Сообщение.Сообщить();

И это не смотря на то, что "ВыводВОкноСообщенийИнформационныхСообщений" принудительно устанавливается в Ложь.
Похоже, что обработка не смотрит на этот флаг. Или я чего-то не понимаю.

В итоге, проблема решилась обрамлением вызова Сообщение.Сообщить() в директиву "#Если Клиент Тогда"

А, ведь, в предыдущей версии все вызовы "Сообщить" (там не использовалось сообщение пользователю) были обрамлены в "#Если Клиент Тогда". Но в новой версии это убрали.
ЗАЧЕМ???

Итог. Убил кучу времени, проклял все 1С и ближайших родственников.

четверг, 21 марта 2013 г.

Openshift vs Green FiLin

Пытаясь завести Redmine на сервере Openshift случайно вызвал дьявола начал изучать Ruby.
Естественно, так или иначе, кривая вывела меня на Bundler (после того, как я утомился бесконечно вводить gem install и читать сообщения о новых неразрешенных зависимостях).

Так, вот, товарищи, статье на хабре не верьте. Точнее верьте, но не во всем.
Для установки gem-ов в определенную папку нужно использовать не:
bundle install ./vendor/bundler_gems
А вовсе даже:
bundle install --path ./vendor/bundler_gems
Спасибо Ирландскому Пингвину и опции --path.


Звуки кафе

Для создания рабочей обстановки сайт со звуками кафе.

вторник, 19 марта 2013 г.

КД, обработчики событий и комментарии

Уже второй раз попадаюсь на теме комментариев в обработчиках событий в ПКО. Причем, второй раз меня туда "попали" типовые правила конвертации из 7.7 в 8.2
В чем суть.
Суть в том, что обработка очень нервно относится к комментариям в обработчиках событий.
В некоторых случаях (в каких именно не тестировал) в обработчиках пропадают переносы строк, а следовательно если где-то внутри конструкции "Если ... Тогда ... КонецЕсли" есть комментарий, то этот самый "КонецЕсли" оказывается закомментированным.
Что очень не нравится обработке загрузки/выгрузки и она вываливается с ошибкой, что-то вроде "не найдено "КонецЕсли". В первый раз это меня поставило в тупик - вроде бы код корректный, а не работает. И уже в отладке выяснилось в чем причина.
Если кому интересно, то в стандартных правилах помощника перехода на 8-ку такой код есть в ПКО "НоменклатураГТД", в событии "ПослеЗагрузки".

Во общем, я бы не советовал использовать в обработчиках комментарии. Во избежание.