воскресенье, 8 апреля 2012 г.

Фиксация шапки в СКД

Не могу не поставить сам себе ссылку на статью о фиксации шапки в СКД с замечательного сайта 1cskd.ru.

P.S.: Поскольку, замечательный сайт сейчас лежит, а я не могу остаться без шпаргалки, вынесу код сюда:
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Результат);
    ПроцессорВывода.НачатьВывод();
    ТаблицаЗафиксирована = Ложь;
    Пока Истина Цикл
        ЭлементРезультата = ПроцессорКомпоновкиДанных.Следующий();
        Если ЭлементРезультата = Неопределено Тогда
            Прервать;
        Иначе
            ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
            Если не ТаблицаЗафиксирована и ЭлементРезультата.ЗначенияПараметров.Количество() >  0 Тогда
                ТаблицаЗафиксирована = Истина;
                ЭлементыФормы.Результат.ФиксацияСверху = ЭлементыФормы.Результат.ВысотаТаблицы - 1;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    ПроцессорВывода.ЗакончитьВывод();

2 комментария:

Андрей Данилюк комментирует...

Да. 8.2 с методами объекта Отчет рулит в решении данного вопроса :)

Green FiLin комментирует...

Рулит не то слово!
Но я не совсем понял как строка "ДокументРезультат.ФиксацияСверху = 8;" поможет узнать мне высоту самой шапки.
Часто бывает, что ТабличныйДокумент у меня и так есть, так как я работаю с СКД из кода.

Отправить комментарий